Important Announcements

This is where we notify our customers of any downtime, maintenance or issues that would impact our services.

(Resolved) WordPress - WPBakery Page Builder Vulnerability
We have been made aware of a security vulnerability in "WPBakery Page Builder", a popular page builder plugin for WordPress that has been used on ...
Tue, 13 Oct, 2020 at 4:57 PM